ElNotes

Руководство пользователя

Версия 2.2.13
16 сентября 2022 г.
Авторские права © Элита Групп, 2015-2022

Приложение ElNotes, разработанное компанией «Элита Групп», предназначено для создания и хранения текстовых и голосовых заметок и управления ими на тифлоорганайзерах ElBraille и на персональных компьютерах под управлением Microsoft Windows.
Приложение ElNotes позволяет быстро создавать текстовые и голосовые заметки, используя специальные комбинации управляющих клавиш, и затем при необходимости экспортировать их в файлы с расширением .txt или .mp3, соответственно. Эти файлы сохраняются в выбранную папку, и в дальнейшем их можно читать и прослушивать как с помощью других приложений на ElBraille, так и на других устройствах.

Установка, активация и обновление приложения

Если вы используете приложение ElNotes на ElBraille, оно уже будет установлено на вашей системе. Если же вы приобрели программу отдельно, вам нужно будет установить программу на свой компьютер.

При первом запуске программы будет создан файл базы данных заметок. Он будет находиться в папке Мои документы\ElNotes и будет иметь имя elnotes.eldb.

Затем, если вы приобретали программу отдельно, вам будет предложено активировать приложение ElNotes. Для активации приложения необходим доступ к сети Интернет. Чтобы активировать приложение, укажите серийный номер и ключ активации, которые вы получили при покупке приложения, и нажмите кнопку «Активировать».
Если вы приобрели персональную лицензию, эта информация будет указана в заголовке основного окна программы, а также в окне «О программе». Если вы используете elNotes на тифлоорганайзере ElBraille, у вас предустановлена неограниченная лицензия.

Система активации продукта

Вы также можете отложить активацию продукта и воспользоваться ознакомительным периодом в 30 дней, чтобы оценить возможности приложения и принять решение, хотите ли вы его использовать.
Чтобы временно использовать приложение ElNotes без активации, в окне активации продукта нажмите кнопку «OK».

Вы можете вернуться к этому окну и активировать продукт в любое время. Для этого в меню «Справка» выберите пункт «О программе» и в появившемся окне, в котором также содержится информация о версии продукта и количестве оставшихся дней ознакомительного периода, нажмите кнопку «Активировать».

Окно «О программе»

В этом же окне вы можете проверить наличие обновлений программы, щёлкнув по ссылке «Проверить обновления». Если новая версия есть, вы увидите диалог обновления программы; если вы используете последнюю на данный момент версию программы, появится сообщение о том, что обновлений ElNotes нет.

Примечание: Если в параметрах программы установлен флажок «Автоматически проверять обновления», ElNotes будет автоматически проверять наличие обновлений при каждом запуске программы.

Интерфейс приложения

Рассмотрим интерфейс приложения ElNotes.
Окно приложения разделено на три области: список категорий, список заметок и область просмотра заметки.

Основное окно программы

Примечание: Если при запуске программы база данных заметок не будет найдена, откроется окно настроек места хранения заметок, где вы можете указать размещение существующей базы данных заметок.
Примечание: На ElBraille программу ElNotes можно запустить, кратко нажав клавишу E4. Для запуска приложения на персональном компьютере используйте комбинацию клавиш Ctrl+Alt+E.

Список категорий

Сразу после установки приложения список категорий содержит два элемента: «Все категории» и «Без категории». Эти категории нельзя удалить. После названия каждой категории в скобках отображается количество заметок в этой категории.

Примечание: вы можете отключить отображение элемента «Все категории» в настройках ElNotes. Подробнее об этом см. в разделе «Параметры программы».

Вы можете создавать столько категорий, сколько вам необходимо, и называть их так, как пожелаете.
Чтобы создать новую категорию, выберите в меню «Файл» пункт «Создать категорию».
Откроется окно, в котором вам будет предложено указать название категории. Название не может быть длиннее 100 символов.

Окно добавления категории

Вы также можете вызвать это окно, нажав Alt+Shift+N или Ctrl+Alt+N (если вы работаете на ElBraille, нажмите Точки 6+7+8+Пробел или Точки 3+6+8+Пробел, затем латинскую букву n, то есть Точки 1+3+4+5+8 при использовании русской таблицы Брайля или Точки 1+3+4+5 при использовании американской таблицы Брайля). Также можно воспользоваться контекстным меню списка категорий. Чтобы войти в контекстное меню, нажмите Клавишу контекстного меню (Правый Shift+Точка 2+Пробел).

Примечание: Если у вас установлена программа экранного доступа NVDA, сочетание клавиш Ctrl+Alt+N, по умолчанию, будет инициировать запуск или перезапуск этой программы.

Чтобы воспользоваться контекстным меню списка категорий, вам необходимо находиться в этом списке. В зависимости от того, выделена в данный момент созданная вами категория или же категория по умолчанию, в контекстном меню будут доступны или недоступны команды редактирования и удаления категорий.

Контекстное меню списка категорий

Также для удаления и редактирования ваших категорий вы можете использовать клавиатурные команды.
Чтобы переименовать выбранную категорию, нажмите Ctrl+F2 (Точки 1+3+8+Пробел, затем Точки 1+2).
Чтобы удалить выбранную категорию, нажмите Delete (Левый Shift+Точки 1+4+5).

Список заметок

Чтобы перейти в список заметок, находясь в списке категорий, нажмите Tab (Точки 4+5+Пробел) или Enter (Точка 8). Список заметок содержит ваши заметки, сгруппированные по категориям. Чтобы увидеть все ваши заметки в одном списке, сделайте активной категорию «Все категории». Вы можете воспользоваться фильтром, чтобы просматривать только текстовые или только голосовые заметки.
Чтобы использовать фильтр, в меню «Вид» выберите пункт «Фильтр».
Вы можете также сортировать заметки по названию или по дате последнего изменения.
Чтобы прослушать информацию о фильтрах и сортировке, нажмите сочетание клавиш Insert+End (Левая кнопка-качелька вверх+Правая кнопка-качелька вверх).
Чтобы в списке заметок всех категорий узнать, к какой категории относится конкретная заметка, нажмите Insert+PageDown (Левая кнопка-качелька вниз+Правая кнопка-качелька вниз).

Меню фильтра

Вы можете удалить заметку, выбрав пункт «Удалить выбранные заметки» из меню «Правка». Также для этого вы можете выбрать заметку и нажать Delete (Левый Shift+Точки 1+4+5) или воспользоваться командой контекстного меню.

В меню «Правка» и в контекстном меню находится также команда «Копировать текст заметки». Если вы выполните эту команду, то название заметки и её текст будут скопированы в буфер обмена. Вы можете использовать эту возможность, чтобы создать другую, похожую заметку, или чтобы использовать текст заметки в другом приложении.
Если вы применили эту команду к голосовой заметке, то скопировано будет только название заметки.
Если вы выделили несколько заметок и выполнили эту команду, скопирован будет только текст первой из выделенных заметок.
Вы можете выбрать несколько заметок в списке обычным способом, удерживая нажатой клавишу Shift и выделяя заметки подряд или удерживая клавишу Ctrl и выделяя нужные заметки клавишей Пробел, а затем удалить их все сразу, нажав Delete или выбрав соответствующую команду в меню приложения или в контекстном меню.
Появится окно подтверждения удаления заметок. Это удобно, поскольку вы не удалите свои заметки случайно.

Окно подтверждения удаления заметок

Выберите «Да», если хотите удалить все выбранные заметки, или выберите «Нет», если хотя бы одна из заметок выбрана ошибочно.

Чтобы переименовать выбранную заметку, нажмите F2 (Точки 1+8+Пробел, затем Точки 1+2). Вы окажетесь в поле редактирования названия заметки. Измените название и нажмите Enter (Точка 8). Если вы передумали и не хотите переименовывать заметку, нажмите Escape (Точки 1+3+5+6+Пробел). Вы также можете переименовать заметку, выбрав пункт «Переименовать» в её контекстном меню.

Чтобы быстро изменить категорию выбранных заметок, нажмите Ctrl+M (Точки 3+8+Пробел, затем латинскую букву m, то есть Точки 1+3+4+8 при использовании русской таблицы Брайля или Точки 1+3+4 при использовании американской таблицы Брайля). Выберите нужную категорию из списка и нажмите Enter (Точка 8). Вы также можете изменить категорию заметки из контекстного меню, выбрав пункт «Изменить категорию». В появившемся подменю выберите одну из 12 последних категорий и нажмите Enter (Точка 8).

Вы также можете выполнить поиск заметки. Чтобы это сделать, нажмите Ctrl+F (Точки 3+8+Пробел, затем латинскую букву f, то есть Точки 1+2+4+8 при использовании русской таблицы Брайля или Точки 1+2+4 при использовании американской таблицы Брайля). Вы также можете перейти клавишей Tab по окну до тех пор, пока не обнаружите строку поиска. Введите искомый текст и нажмите Enter (Точка 8).
Поиск производится как по названию, так и по тексту заметок. Если что-либо будет найдено, вы окажетесь в списке заметок на первой заметке, где встречается строка, которую вы искали. При этом в списке отобразятся только заметки, содержащие искомую строку. Отобразится число найденных результатов, а также число заметок, в которых производился поиск.
Чтобы очистить поле поиска и таким образом сбросить фильтр заметок, нажмите Escape (Точки 1+3+5+6+Пробел) или щёлкните кнопку «Очистить строку поиска».

Область просмотра заметки

Чтобы перейти в область просмотра заметок, выберите в списке заметок нужную заметку и нажмите Enter (Точка 8). Область просмотра заметки позволяет просматривать содержимое заметки.
Если в списке заметок выделена текстовая заметка, то область просмотра заметки содержит название заметки, категорию, к которой она относится, и текст заметки.

Область просмотра текстовой заметки

Чтобы вернуться в список заметок, нажмите Escape (Точки 1+3+5+6+Пробел). Кроме того, для циклического переключения между списком заметок и областью просмотра заметки вы можете нажимать Ctrl+Enter (Точки 3+8+Пробел, затем Точку 8).

В области просмотра заметки вы можете изменить название, текст заметки или категорию. Изменения сохраняются автоматически.

Если в списке вы выбрали текстовую заметку, вы можете искать слово или фразу в тексте этой заметки. Чтобы это сделать, нажмите Ctrl+F (Точки 3+8+Пробел, затем латинскую букву f, то есть Точки 1+2+4+8 при использовании русской таблицы Брайля или Точки 1+2+4 при использовании американской таблицы Брайля). Откроется диалог поиска.

Диалог поиска по заметке

Если по вашему запросу что-либо найдено, вы окажетесь на соответствующем месте в заметке. Для продолжения поиска нажмите F3 (Точки 1+8+Пробел, затем Точки 1+4).
Когда ElNotes завершит поиск по заметке, вас спросят, нужно ли искать с начала текста.
Если ничего не будет найдено, программа выведет соответствующее окно.

Если в списке заметок вы выбрали голосовую заметку, то область просмотра заметки содержит плеер для прослушивания заметки.

Область просмотра голосовой заметки

Здесь находятся обычные для плеера кнопки управления воспроизведением, а также ползунки настройки громкости и скорости воспроизведения.

Создание заметок

В ElNotes Вы можете создать текстовую или голосовую заметку одним из следующих способов:

  1. Если вы работаете на ElBraille, для создания текстовой заметки нажмите E4, а для создания голосовой заметки нажмите и удерживайте E4, пока не услышите щелчок. Отпустите клавишу сразу после щелчка.
  2. Войдите в меню «Файл» и выберите пункт «Создать текстовую заметку» или «Создать голосовую заметку».
  3. Чтобы создать текстовую заметку, нажмите Ctrl+N (Точки 3+8+Пробел, затем латинскую букву n, то есть Точки 1+3+4+5+8 при использовании русской таблицы Брайля или Точки 1+3+4+5 при использовании американской таблицы Брайля). Чтобы создать голосовую заметку, нажмите Ctrl+Shift+N (Точки 3+7+8+Пробел, затем латинскую букву n, то есть Точки 1+3+4+5+8 при использовании русской таблицы Брайля или Точки 1+3+4+5 при использовании американской таблицы Брайля).
  4. Находясь в области категорий, вызовите контекстное меню и выберите желаемый пункт.

Во всех этих случаях откроется окно создания заметки.

Если вы создаёте текстовую заметку, это окно содержит следующие элементы:

Окно создания текстовой заметки

Заполните все поля в этом окне и нажмите кнопку «Сохранить». Если вы передумали создавать заметку, нажмите кнопку «Отмена».

Примечание: Если при написании текста заметки вам необходимо добавить символ табуляции (например, для разделения текста на две колонки), используйте сочетание клавиш Ctrl+Tab (Точки 5+6+Пробел).

Если вы создаёте голосовую заметку, окно создания заметки содержит название заметки, кнопку «Начать запись» и список категорий.

Окно создания голосовой заметки

Примечание: Если к вашему компьютеру не подключён микрофон, при попытке создать голосовую заметку вы получите сообщение об ошибке.

Чтобы записать голосовую заметку, дойдите до кнопки «Начать запись», а затем нажмите клавишу Пробел, или нажмите и удерживайте клавишу E4, если вы работаете на ElBraille. Начнётся запись со встроенного или подключённого к устройству микрофона. В это время на кнопке написано «Идёт запись».
Чтобы приостановить запись, снова нажмите Пробел или отпустите E4. Надпись на кнопке снова сменится на «Начать запись». Чтобы продолжить запись, снова нажмите Пробел или нажмите и удерживайте E4.

Совет: Для более эффективного использования записи мы советуем отключать обучающие сообщения JAWS. Если эти сообщения включены, вы можете слышать JAWS в начале записи голосовой заметки.

Чтобы сохранить голосовую заметку, нажмите кнопку «Сохранить». Если вы передумали создавать эту заметку, нажмите кнопку «Отмена» или Escape (Точки 1+3+5+6+Пробел). Вас спросят, хотите ли вы сохранить заметку или отменить её.

Прослушать сохранённую заметку вы сможете в области просмотра заметки.

Примечание: Если вы работаете на ElBraille, для быстрого создания голосовой заметки вы можете нажать и удерживать клавишу E4, находясь в главном окне ElNotes. Запись начнётся через 1 секунду после щелчка и будет продолжаться, пока вы удерживаете клавишу. Когда вы отпустите клавишу E4, новая заметка будет сохранена с именем «Голосовая заметка без названия».

Экспорт и импорт заметок

Вы можете экспортировать свои заметки в текстовые или mp3-файлы, чтобы получить к ним доступ из других приложений или на других устройствах. Каждая заметка будет выгружена в отдельный пронумерованный файл, в указанную вами папку.
Экспортировать можно как все заметки сразу, так и все заметки какой-либо категории или же избранные вами заметки.

Чтобы экспортировать все заметки сразу, выполните следующие действия:

Чтобы экспортировать выбранные вами заметки, сначала выделите желаемые заметки. Это можно сделать в списке заметок. Вы можете выбирать заметки по одной или воспользоваться командой «Выбрать все заметки категории» из меню «Правка». Используйте эту возможность, если вам необходимо экспортировать все заметки какой-либо одной категории.
Затем в меню «Файл» выберите пункт «Экспортировать выбранные заметки в папку» или нажмите Ctrl+S (Точки 3+8+Пробел, затем латинскую букву s, то есть Точки 2+3+4+8 при использовании русской таблицы Брайля или Точки 2+3+4 при использовании американской таблицы Брайля). Укажите папку для экспорта и нажмите кнопку «OK».

Внимание! Выбирайте папку осмотрительно, так как по нажатии кнопки экспорта в выбранной вами папке появится столько файлов, сколько заметок вы выбрали для экспорта. Так, например, мы не рекомендуем использовать для экспорта заметок Рабочий стол, поскольку вам может быть неудобно удалять большое количество заметок с Рабочего стола Windows.

Вы также можете экспортировать заметки в файл базы данных ElNotes, чтобы затем использовать этот файл на другом ElBraille или компьютере, где установлена программа ElNotes. Для этого выполняйте те же действия, что были описаны выше, только из меню «Файл» выбирайте соответственно пункты «Экспортировать все заметки в ELDB-файл» или «Экспортировать выбранные заметки в ELDB-файл». Чтобы быстро сделать копию текущей базы данных заметок, выберите пункт «Сохранить полную копию текущей базы данных ElNotes».

Если вы экспортировали заметки в папку с файлами или в ELDB-файл и хотите объединить эти заметки с вашим текущим списком заметок, выберите из меню «Файл» соответственно пункты «Импортировать заметки из папки» или «Импортировать заметки из ELDB-файла». Дублирующиеся заметки импортированы не будут.
Вы также можете импортировать произвольные текстовые файлы из любой папки. Для этого также выберите пункт «Импортировать заметки из папки» из меню «Файл». Каждая заметка, импортированная из произвольного текстового файла, будет иметь имя этого файла в качестве названия.

Параметры программы

Вы можете настроить параметры ElNotes по своему вкусу, выбрав пункт «Параметры» в меню «Файл» или нажав Ctrl+Shift+O (Точки 3+7+8+Пробел, затем латинскую букву o, то есть Точки 1+3+5+8 при использовании русской таблицы Брайля или Точки 1+3+5 при использовании американской таблицы Брайля).

В окне «Параметры» имеются следующие три вкладки «Данные», «Голосовые заметки», «Общие»:

Контактная информация

По всем вопросам, связанным с программой ElNotes, обращайтесь, пожалуйста, в компанию «Элита Групп».
Веб-сайт: http://elitagroup.ru
Номер телефона: +7 (495) 748-96-77
Факс: +7 (495) 706-50-64
Электронная почта: support@elitagroup.ru