ElPicsPrint

Руководство пользователя

Версия 2.5.0
15 февраля 2021 г.
Авторские права © Элита Групп, 2015 — 2021

Приложение ElPicsPrint, разработанное компанией «Элита Групп», предназначено для создания, редактирования и печати рельефных изображений на принтерах для печати по Брайлю.
Приложение ElPicsPrint позволяет открывать изображения в форматах svg, bmp, jpg и png, а также в собственных форматах elpe и elpp. Формат elpe представляет собой редактируемый svg-файл, содержащий дополнительную информацию для работы программы. Формат elpp содержит информацию в виде точек, готовую к выводу на печать, и исключает возможность редактирования.
Вместе с программой ElPicsPrint поставляется базовый набор изображений в форматах jpeg и elpe. Эти изображения вы найдёте в вашей пользовательской папке «Мои документы\ElPicsPrint».

Установка и активация приложения

Запустите на вашем компьютере установочный файл приложения ElPicsPrint. В появившемся диалоговом окне выберите желаемый язык интерфейса и нажмите кнопку «OK».

Выбор языка

Откроется мастер установки. Следуйте инструкциям мастера. Для продолжения установки на каждом шаге нажимайте кнопку «Далее». Если вы передумали и не хотите устанавливать приложение, нажмите кнопку «Отмена». По окончании работы мастера нажмите кнопку «Готово».
Вы можете запустить приложение ElPicsPrint сразу по завершении установки с помощью ярлыка на рабочем столе или из меню «Пуск». Если вы уже активировали приложение ElPicsPrint ранее и сохранили активацию, программа сразу же откроется. Если вы установили ElPicsPrint в первый раз или ранее не активировали программу, вам будет предложено активировать приложение или использовать его в демонстрационном режиме до окончания ознакомительного периода.

Окно активации

Введите серийный номер и ключ активации, затем нажмите кнопку «Активировать». Для активации необходим доступ к сети Интернет. Если активация прошла успешно, вы получите сообщение: «Активация успешно завершена». Если вы хотите использовать программу в демонстрационном режиме, нажмите кнопку «OK».
Теперь приложение ElPicsPrint установлено и готово к работе.

Описание приложения

Программа предназначена для создания, редактирования и печати тактильной графики на принтерах для печати по Брайлю. Данная версия поддерживает принтеры Basic-D, Everest-D, BrailleBox и FanFold-D от компании Index Braille; принтеры VP Delta, VP Columbia, VP EmBraille, VP Max, VP SpotDot, VP Elite, VP Premier от компании ViewPlus; принтеры Romeo и Juliet от компании Enabling Technologies.
Приложение ElPicsPrint поддерживает следующие типы файлов:

Программа имеет три основных режима работы: начальный режим, режим редактирования и режим предпросмотра результата и вывода на печать.
При обычном запуске из меню «Пуск» или с помощью ярлыка на Рабочем столе открывается начальный режим. В этом режиме можно создать новый рисунок или открыть существующий файл.
После создания нового файла или открытия существующего программа переходит в режим редактирования. Это основной режим работы, позволяющий создавать и редактировать объекты документа.
Из режима редактирования можно перейти в режим предпросмотра, позволяющий оценить предварительный результат, который будет получен при печати изображения, а также отправить документ на печать.
Во всех режимах вы можете ознакомиться со справкой, отредактировать настройки программы, а также посмотреть сведения о программе.

Примечание: При запуске программы с помощью ярлыка на рабочем столе или из меню Пуск, или при открытии файла из проводника Windows, открывается новый экземпляр приложения. Возможна работа нескольких экземпляров приложения одновременно и копирование элементов из одного документа в другой.

Интерфейс приложения

Рассмотрим интерфейс приложения ElPicsPrint в каждом из режимов работы.

Основное пространство окна занимает рабочая область. Справа располагаются элементы управления программы.

Непосредственно после запуска окно программы выглядит следующим образом:

Интерфейс приложения ElPicsPrint в начальном режиме

Во всех режимах работы программы главное окно содержит следующие кнопки:

В начальном режиме окно программы так же содержит следующие элементы:

Указанные на данном этапе размеры полей и формат бумаги будут рекомендуемыми для данного документа, но могут быть легко изменены в режиме редактирования.

Режим редактирования

После открытия файла или создания нового проекта программа переходит в режим редактирования:

Интерфейс приложения ElPicsPrint в режиме редактирования

В режиме редактирования окно программы, помимо общих для всех режимов, содержит следующие элементы:

Режим предпросмотра и печати

Для предварительного просмотра результатов и вывода документа на печать нажмите кнопку «Режим печати». Программа переходит в режим предпросмотра и печати:

Интерфейс приложения ElPicsPrint в режиме предпросмотра и печати

В режиме предпросмотра и печати окно, помимо общих для всех режимов, содержит следующие элементы:

После открытия elpp-файла программа открывается в ограниченном режиме предпросмотра и печати. В этом режиме пользователю доступны только поворот листа, выбор подключённого принтера (формат поддерживает только принтеры от компании Index Braille), установка количества печатаемых копий, флажок режима быстрой печати и кнопка «Печать»:

Интерфейс приложения ElPicsPrint в режиме предпросмотра и печати ELPP

Параметры программы

Вы можете настроить параметры ElPicsPrint, щёлкнув кнопку «Параметры» в основном окне программы.

Окно параметров программы

Доступны следующие настройки:

Создание изображений

Программа ElPicsPrint версии 2 представляет собой графический редактор, содержащий инструменты, необходимые для подготовки и печати тактильной графики. Этот редактор доступен в режиме редактирования, который является основным после открытия существующего документа или создания нового.
Документ может содержать объекты трёх типов: контуры, растровые изображения и надписи.

При создании нового документа учитываются параметры отступов и выбранного формата бумаги. Создаваемый документ будет иметь пропорции выбранного формата с учётом отступов. Следует иметь в виду, что при выборе другого формата бумаги в режиме редактирования или предпросмотра исходный документ будет масштабирован в соответствии с новым форматом, и при последующем редактировании или создании объектов существует вероятность, что некоторые из них окажутся вне границ исходного документа, так как он может иметь пропорции, отличные от пропорций нового формата. Это может привести к тому, что при возврате к исходному формату или формату, имеющему другие пропорции, часть информации может выйти за границы области печати. Вернуть все объекты в зону видимости можно с помощью пункта «Показать все» контекстного меню рабочей области.

Инструменты рисования

Внешний вид панели инструментов рисования представлен ниже.

Панель инструментов рисования

Панель можно перемещать по экрану, потянув за оранжевый прямоугольник, расположенный в верхней или левой её части. В зависимости от ваших предпочтений панель можно расположить как вертикально, так и горизонтально. Ориентация панели изменяется автоматически при её перемещении к границам окна. Её также можно изменить, дважды щёлкнув по оранжевой области.

Вам доступны следующие инструменты, позволяющие добавлять объекты одного из вышеуказанных типов:

Инструмент «Стрелка»Инструмент «Стрелка». Этот инструмент активен, если не выбран никакой другой. Позволяет производить выделение и редактирование объектов.
Инструмент «Карандаш»Инструмент «Карандаш». С помощью этого инструмента можно рисовать линии, которые могут состоять из прямых сегментов и из кривых Безье. Для рисования прямых участков используйте однократный щелчок левой кнопкой мыши по изображению. Чтобы нарисовать непрерывную кривую, нажмите и удерживайте левую кнопку мыши. Чтобы продолжать рисовать прямые участки, отпустите левую кнопку мыши и снова щёлкните по изображению. Чтобы завершить рисование незамкнутого контура, дважды щёлкните левой кнопкой мыши по изображению; чтобы завершить рисование замкнутого контура, соедините начальную и конечную точки контура, тогда рисование завершится автоматически. Вы можете рисовать горизонтальные и вертикальные линии, удерживая клавишу Shift.
Инструмент «Фигуры»Инструмент «Фигуры». Позволяет рисовать многоугольники с количеством углов от 3 до 12. Чтобы начать рисование, щёлкните левой кнопкой мыши. Чтобы завершить рисование, щёлкните левой кнопкой ещё раз. Чтобы сохранить пропорции фигуры, нажмите клавишу Shift до начала рисования и удерживайте её во время рисования.
Инструменты «Прямоугольник» и «Эллипс»Инструменты «Прямоугольник» и «Эллипс» позволяют рисовать соответствующие фигуры. Чтобы нарисовать квадрат или круг, используйте эти инструменты, нажав и удерживая клавишу Shift.
Инструмент «Изображение»Инструмент «Изображение» позволяет добавить в документ любое растровое изображение из файла, ранее сохранённого на вашем компьютере или переносном носителе. Поддерживаются следующие форматы: jpeg, png и bmp.
Инструмент «Волшебная палочка»Инструмент «Волшебная палочка» позволяет добавить в документ линию, очерчивающую область определённого цвета. Порог чувствительности можно изменить в параметрах инструмента. Результатом работы «Волшебной палочки» является замкнутая полилиния, состоящая из коротких прямых отрезков.
Инструмент «Текст»Инструмент «Текст» позволяет добавить в документ текстовую область, содержание которой впоследствии можно редактировать.
Инструмент «Ластик»Инструмент «Ластик». С помощью этого инструмента можно сделать прозрачными части растровых изображений и контуров, содержащихся в документе. Возможно изменение размера и формы инструмента. Может применяться к одному или нескольким выбранным объектам одновременно. При установленном флажке «Режим восстановления» инструмент делает вновь видимыми обрабатываемые части объектов. Включить этот флажок во время работы инструмента можно, нажав левую клавишу Shift на клавиатуре. Однократное нажатие включает и выключает режим; вы также можете нажать и удерживать клавишу, тогда режим будет работать, пока вы не отпустите её. Кнопка «Сброс» позволяет удалить все маски прозрачности и вернуть выделенные объекты в исходное состояние. Удержание левой клавиши Ctrl на клавиатуре позволит временно отключить инструмент «Ластик» для трансформации выделенных объектов или для выбора другого объекта.

Выделение и трансформация

Вы можете выделить каждый объект документа, щёлкнув по нему левой кнопкой мыши. Вы также можете выделить несколько объектов, удерживая клавишу Shift, или выделить все объекты с помощью комбинации клавиш Ctrl+A. Вы также можете очертить область выделения, используя левую кнопку мыши. Все объекты, частично или полностью попавшие в эту область, будут выделены.

Выделение контура

Чтобы снять выделение, нажмите клавишу Escape или щёлкните по пустой области документа.

Вы можете выполнять с выделенным объектом или группой объектов ряд действий: копировать (Ctrl+C), удалять (Delete), перемещать, изменять размер и вращать путём перемещения центральной и угловых точек ограничивающего прямоугольника. Для сохранения пропорций нажмите клавишу Ctrl до начала трансформации и удерживайте её во время трансформации. Для трансформации относительно центральной точки нажмите и удерживайте клавишу Shift. Удерживание клавиши Ctrl во время вращения позволяет вращать объект с шагом в 15°. Чтобы изменить местоположение объекта, перемещайте центральную точку ограничивающего прямоугольника или перетащите выделенную область, удерживая клавишу Ctrl.

При наведении указателя мыши на угловые и центральную точки ограничивающего прямоугольника, а также при трансформации объектов появляется подсказка с координатами данной точки относительно ЛЕВОГО ВЕРХНЕГО угла документа. Если в настройках программы включено отображение сетки и привязка к сетке, при перемещении этих точек будет происходить округление координат с учётом заданного шага сетки.

Редактирование контуров

Чтобы перевести контур в режим редактирования, дважды щёлкните по нему левой кнопкой мыши. При переводе в режим редактирования узловые точки контура помечаются зелёным цветом. В этом режиме вы можете перемещать и удалять эти точки.

Режим редактирования контура

Если редактируемая точка является опорной точкой кривой Безье, то становятся видимыми также вспомогательные точки кривой, перемещая которые можно изменять её изгиб. Чтобы удалить опорную точку, дважды щёлкните её. Чтобы добавить опорную точку, дважды щёлкните по свободному участку контура. Впоследствии эту точку можно переместить.

Режим редактирования точки

Щёлкнув по участку контура, вы можете выделить редактируемый сегмент, при этом появляются вспомогательные опорные точки сегмента, перемещая которые можно изменять кривизну участка контура.

Режим редактирования сегмента

Вы можете изменять такие свойства контуров как цвет контура, цвет заливки, толщину и признак пунктирности выбрав из контекстного меню контура пункт «Настройки контура».

Меню  «Настройки контура»

Для изменения толщины контура передвиньте соответствующий ползунок. При этом во всплывающей подсказке вы увидите примерную толщину контура в точках по Брайлю. Значение «1x» означает одинарную толщину, «2x» двойную, «2x+» означает что контур будет напечатан двойным рядом точек, с некоторым расстоянием между рядами.

Пример контуров с различной толщиной

Вы можете сделать контур пунктирным, установив флажок «Пунктирная линия» в меню «Настройки контура». Такой контур будет напечатан прерывистым рядом точек Брайля. Рекомендуется применять данную возможность только для контуров без заливки цветом.

Пример пунктирного контура

Вы можете изменить цвет контура и внутренней заливки в меню «Настройки контура». Цвет контура не влияет на результат печати тактильного изображения. При выборе цвета заливки необходимо учитывать возможность заполнения точками Брайля цветных объектов документа (для этого необходимо установить флажок «Заполнять точками цветные объекты» после перехода в режим предпросмотра и печати). Выбирайте цвет заливки наиболее удобный с точки зрения тактильного восприятия, а не исходя из реального цвета рисуемых объектов. Вполне допускается листву дерева, к примеру, залить черным, если с точки зрения тактильного восприятия это будет оптимально. На рисунке ниже показан результат заливки контуров точками в зависимости от цвета и выбранного принтера.

Возможные цвета заливки и из печать при установленном флажке «Заполнять точками цветные объекты» в режиме печати

Вы можете объединить несколько контуров в один путем сложения, вычитания или пересечения, что позволяет создавать контуры сложной геометрической формы. Для этого выделите два или более контуров и из контекстного меню выберите пункт «Объединить» и далее выберите желаемый вариант объединения. Доступно при выделении двух и более контуров. Если в результате операции возвращается пустой объект, операция будет отменена. Доступны следующие варианты объединения:

Для разделения контура на отдельные фигуры выберите пункт контекстного меню «Разделить» (Alt+U).

Вы также можете применить к выбранным контурам инструмент «Ластик», который делает прозрачными участки, попавшие в зону его действия.

Вы можете сгруппировать несколько контуров и других объектов в один объект (группу). Для этого выделите желаемые объекты и из контекстного меню выберите пункт «Сгруппировать» (Ctrl+G). Прежде чем редактировать отдельные объекты, входящие в группу, её нужно разгруппировать. Для этого выберите пункт контекстного меню «Разгруппировать» (Ctrl+U) или дважды щёлкните по объекту группы, после чего программа предложит разгруппировать его.

Вы можете изменять Z-индекс контура, то есть помещать его на передний или на задний план относительно других объектов документа. Для этого из контекстного меню выберите пункт «Изменить Z-индекс» и далее выберите желаемое действие.

Редактирование текстовых полей

Вы можете вращать и перемещать выделенное текстовое поле, как и другие объекты в документе. Чтобы перейти в режим редактирования содержимого текстового поля, дважды щёлкните это поле. В этом режиме вы можете редактировать текст по своему усмотрению, выполняя обычные действия, такие как копирование и вставка информации. По мере ввода или редактирования текста программа автоматически конвертирует введённый текст в текст по Брайлю с помощью выбранной таблицы трансляции. Ширина текста по Брайлю может несколько отличаться от ширины исходного текста.

Режим редактирования текста

Вы можете изменить таблицу трансляции Брайля с помощью пункта «Таблица трансляции Брайля Liblouis» контекстного меню текстового поля.

Выбор таблицы трансляции Брайля из контекстного меню поля

Если корректная конвертация с помощью выбранной таблицы невозможна, фон текстового поля будет подсвечен розовым цветом, а при попытке открытия и предпросмотра документа будет показано предупреждение.

Сообщение при выборе неверной таблицы трансляции Брайля

Примечание: Программа ищет таблицы в собственном каталоге установки, в подпапке «liblouis\tables». Если нужной таблицы нет в списке доступных, проверьте, содержит ли её файл обязательный атрибут «#-display-name:», который должен задавать отображаемое название таблицы. ElPicsPrint поддерживает только таблицы трансляции литературного Брайля, восьмиточечные таблицы компьютерного Брайля не поддерживаются.

Редактирование растровых изображений

Вы можете вращать, перемещать и изменять пропорции выделенного растрового изображения, являющегося частью документа. Вы также можете применить к изображению инструмент «Ластик», который делает прозрачными участки изображения, попавшие в зону его действия.

По умолчанию открываемый документ полностью располагается в окне программы. При необходимости вы можете изменить масштаб просмотра с помощью колёсика мыши или сочетаний клавиш Ctrl+Плюс и Ctrl+Минус. При использовании мыши изменение масштаба происходит относительно точки, над которой находится указатель мыши, а при использовании клавиатуры — относительно центра видимой части рабочей области. При увеличенном масштабе документ можно двигать с помощью полос прокрутки или с помощью мыши, удерживая клавишу Пробел.

Действия с объектами и контекстное меню

Для выделенных объектов в программе можно применить следующие действия, доступные из контекстного меню или с помощью клавиатурных команд:

Подготовка изображений с помощью сторонних программ

Работа с svg

Программа ElPicsPrint версии 2 поддерживает формат векторной графики svg, поэтому для подготовки изображений вы можете использовать сторонние программы, такие как Adobe Illustrator, CorelDraw, Inkscape и др. или комбинировать их использование с программой ElPicsPrint. Однако при этом необходимо учитывать следующие рекомендации:

Работа с растровыми изображениями

ElPicsPrint версии 2 поддерживает растровые форматы файлов, как и более ранняя версия программы. При открытии рисунка в формате bmp, jpg или png программа создаёт новый документ с учётом выбранного на момент открытия размера бумаги и отступов и добавляет открываемое изображение в этот документ так же, как если бы рисунок был добавлен в документ с помощью инструмента «Изображение». Впоследствии размер и положение рисунка можно изменить обычным способом. Вы также можете выполнять с изображением другие действия: комбинировать несколько изображений в одном документе, применять к ним инструмент «Ластик», добавлять надписи, в том числе поверх имеющихся на изображениях, и т.д.

Вы можете использовать растровые графические редакторы для подготовки изображений или сохранять в виде растровых изображений результат работы векторных графических программ. Для достижения наилучшего результата необходимо соблюдать следующие рекомендации:

При создании растровых изображений вы можете добавлять на них комментарии по Брайлю. Программа распознает эти комментарии и сможет корректно выводить их на печать даже при изменении формата бумаги. Для качественного распознавания текста картинка должна иметь рекомендуемые размеры.
Используйте шрифт Braille, который поставляется с программой ElPicsPrint и устанавливается в систему автоматически. Стандартный размер шрифта: 18 пунктов (7 мм). Текст, набранный другим шрифтом, может быть распознан некорректно или обработан в виде картинки.
Для создания рисунков, содержащих комментарии и условные обозначения внутри графических объектов, необходимо учитывать следующее:

Общие рекомендации для выбора и подготовки изображений

Тактильное изображение для того, кто его исследует, является источником информации об изображённом объекте так же, как обычное полноцветное изображение для зрячего пользователя. Оно должно быть максимально понятным и хорошо распознаваемым. Избегайте изображений со множеством линий и мелких деталей, особенно если они расположены слишком близко друг к другу, так как такое изображение преобразуется в нечитаемый набор точек.

Линии контуров, текст и изображения должны располагаться на расстоянии, достаточном для того, чтобы при преобразовании в точки все детали были чётко различимы. Для просмотра того, как рисунок будет выглядеть на печати, переключайтесь в режим предпросмотра. Визуально оцените логичность и точность расположения точек. Если результат неудовлетворительный, попробуйте уменьшить детализацию, увеличить расстояние между элементами документа или изменить толщину линий.

При выборе растровых изображений для добавления в документ отдавайте предпочтение изображениям с чёткими контурами и однородным фоном. Обычная, даже чёткая фотография, скорее всего, не подойдёт для тактильной печати, поскольку разобрать такое изображение на ощупь невозможно.

Рассмотрим в качестве примера изображение колокольчиков.

Фотография колокольчиков и результата обработки

Если попытаться напечатать подобное фото, то результат будет нечитабельным, даже если будет приведено текстовое описание изображения. Для наших целей лучше использовать рисунок, например, такой:

Рисунок колокольчиков

Слишком мелкие детали на тактильной графике незрячему пользователю распознать невозможно. Разделите изображение на несколько, если это необходимо, или измените изображение, чтобы сохранились только важные элементы. Пользуясь каким-либо графическим редактором, очистите изображение от всех посторонних деталей. Если контуры важных элементов недостаточно чёткие, прорисуйте их. Например, так:

Подготовленный рисунок

Подготовленный таким образом рисунок можно печатать по Брайлю.

Рисунок, обработанный для печати по Брайлю

Вы так же можете добавлять в документ ElPicsPrint растровое изображение, затем, используя инструменты рисования, имеющиеся в программе, обвести интересующие части изображения. После этого нужно удалить исходное растровое изображение из документа.

Подготовленный рисунокРисунок, обработанный для печати по Брайлю

Печать изображения

Для того чтобы иметь возможность печатать изображения по Брайлю с помощью ElPicsPrint, к вашему компьютеру должен быть подключён принтер для печати по Брайлю, а также установлены соответствующие ему драйверы. Для печати рисунков на принтерах от компани Index Braille версия прошивки принтера должна быть не ниже 1.5.3. Если версия прошивки вашего принтера ниже указанной, обратитесь в техническую поддержку компании Элита Групп. Убедитесь, что в группе «Настройки печати» основного окна выбран желаемый принтер.
Укажите желаемое количество копий и размер бумаги. При печати на принтерах от компани Index Braille, выберите в настройках принтера формат бумаги, соответствующий выбранному в программе. Выбирайте альбомную ориентацию выбранного формата бумаги, если это указано в программе.
Чтобы начать печать, щёлкните кнопку «Печать». Рекомендуется использовать синтетическую бумагу или бумагу плотностью 160-200 г/м².

Примечание: Если при печати принтер от Index Braille выдаёт ошибку 213 (Document Max Value — максимальный размер документа), 214 (Document Max Char Per Line — максимальное число символов на строке) или 215 (Document Max Lines Per Page — максимальное число строк на странице), пожалуйста, убедитесь, что в настройках принтера выбран тот же формат бумаги, что и в программе ElPicsPrint. Если ошибка будет повторяться, проверьте настройки формата бумаги на принтере. Число символов в строке и число строк на странице должно быть установлено в максимально допустимые значения.

Контактная информация

По всем вопросам, связанным с программой ElPicsPrint, обращайтесь, пожалуйста, в компанию Элита Групп.
Web-сайт: https://elitagroup.ru
Номер телефона: +7 (495) 748-96-77
Факс: +7 (495) 706-50-64
Электронная почта: support@elitagroup.ru